Programs for Programmers

Operating System Compatibility

Lahey Compatibility Chart

  XP XP Pro x64 Vista 32 Vista 64 Win7/8-32 Win7/8-64
ELF90 v4.0 OK  No[1] OK No[1] OK No[1]
LF90 v4.5 OK No[1] OK No[1] OK No[1]
LF95 v5.0/v5.5/v5.6/v5.7 OK No[1] OK No[1] OK No[1]
LF95 v7.1 Pro/Ent. (with VS2003) OK MAYBE[2] MAYBE[2] MAYBE[2] MAYBE[2] MAYBE[2]
LF95 v7.0/v7.1 Express OK OK OK OK OK OK
LF95 v7.2 Prof. (with VS2008) OK OK OK OK OK OK
LF95 v7.2 Express OK OK OK OK OK OK
LF95 v7.3 Prof. (with VS2010) OK OK OK OK OK OK
LF95 v7.3 Express OK OK OK OK OK OK

[1]: The program uses a 16bit installation and 16bit ED Editor, neither of which are compatible with 64bit Windows. (However, Windows7 Professional and higher edition users can install a Windows add-on called Windows XP Mode, and then the Lahey compiler can be installed within this environment. XP Mode is not available on Windows 8, but a virtual machine could be used.)

[2]: If only the F95 Win32 compiler is required, choose to install the compiler only without Visual Studio .NET and ignore any licence activation error. No editor will be supplied, but the compiler will function OK within the Command Prompt. If the .NET compiler and/or VS2003 are required, the installation is non-trivial but may be accomplished after reading the following two forum threads: http://www.laheyforum.com/showthread.php?t=10692 and
http://www.laheyforum.com/showthread.php?t=10866
(Windows7 Professional and higher edition users can also install Windows XP Mode as mentioned above. Windows 8 users would need to use a virtual machine.)